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Chapter 1 Introduction 

1.1 Intended Use 

Multispectral Imaging System Software is designed to be used with Thorlabs instruments, such as: 

• HSC23V: Multispectral Imaging System 

Many GUI features are common to all instruments while some are device specific. This document will cover the 
common functionalities, and the device-specific customizations are described in the respective instrument 
manual. 

 

Chapter 2 Software Setup 

2.1 Requirements 

The minimum system requirements for running Multispectral Imaging System Software are listed below. 

Minimum Hardware Requirements 

• Monitor Resolution: 800 x 600 pixels  

• Processor (CPU): Intel Core i5 or AMD Athlon II  

• Memory (RAM): 8 GB 

• Hard Drive: 2 GB of Available Disk Space 

• Interface: High-Speed USB 3.0 Connector, Type A  

Software Requirements  

The Multispectral Imaging System Software is compatible with the following operating systems. 

• Windows® 10 (64-bit) 

• Windows® 11 

For operation of the HSC23V Multispectral Imaging System by the Multispectral Imaging System Software, 
Microsoft .NET Framework version 4.7.2 or higher is required and is included with the installation package.  

Note: Do not connect the instrument to your PC before the software has been completely installed. 

2.2 Software Installation 

If the instrument is shipped with a laptop, all required drivers and software are pre-installed. If you wish to install 
the software on another computer or need to re-install the software, please download the installer from Thorlabs’ 
website by: 

• Navigating to the link on the card supplied in the Accessories envelope, or 

• Software tab on the HSC23V Multispectral Imaging System webpage 

The installation package will install all the necessary software and drivers for the instrument. A single computer 
can control several instrument types simply by installing the different installers after one another. A prompt may 
appear asking for “Elevated mode” or “Administrator mode;” please ask your system administrator if you do not 
have administrator privileges. 
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Figure 1 Software Setup Screen 

2.3 Connecting to the PC 

After the software installation has finished, you can connect the instrument to an available USB port on the PC. 
Use only the USB 3.0 Type-A to Micro-B cable that is included with the instrument, as quality can differ between 
producers. If a replacement cable is required, you can find a replacement (CABU31) on the Thorlabs website. 

After connecting the instrument to the PC, the operating system will load the appropriate USB drivers. Please wait 
for this procedure to finish before doing anything else. 

2.4 Starting the Application 

After the software is installed and the instrument is connected to the PC, the application controlling the 
instrument may be started. The Multispectral Imaging System software can be found by clicking the “Start” button 
and then “Thorlabs” (or “Programs” → “Thorlabs” → “FilterWheel” depending on your Windows® version) and 
clicking on the application icon named “FilterWheel”.  

When the Multispectral Imaging System application starts, it will automatically detect all compatible cameras 
connected to the PC. If more than one camera is detected, a list of available devices will be displayed.  Click the 
desired camera entry and click “OK”.   

During program operation, a list of all available devices can be seen by pressing the “Connect” button or the menu 
item “Connect” under the File menu. 
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Figure 2 Select Camera 

 

Chapter 3 Operation 

3.1 Interface Overview 

When the Multispectral Imaging System software starts, the main window is composed of six areas: 

• Main Menu: Contains the command buttons. 

• Setup and Acquisition Controls: Provides access to the setup and acquisition settings of the software. 

• Image Area: This area displays the current image collected by the instrument. 

• Plot Controls Bar: This area selects visualization plots for the current image. 

• Filter Thumbnails: This area displays the most recent image for each filter wheel position. 

• Status Bar: Shows information and status as appropriate. 
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Figure 3 Layout of the Main Window of the Multispectral Imaging System Software at Startup (when a 
HSC23V Instrument is Connected) 

 

 

 

 

 

 

Figure 4 Layout of the Main Menu 
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3.2 Acquiring Data 

Images are acquired from the connected device and processed according to the current settings. Prior to 
proceeding, ensure that the field of view of the imaging system is illuminated with sufficient and even intensity 
from an appropriate light source.  The HSC23V CMOS sensor automatically compensates for dark current; there is 
no explicit feature in the software. 

3.2.1 Finding the Camera 

When the software starts it will automatically detect and read the properties of all compatible cameras connected 
to the computer through USB (refer to Section 2.4). If the program was started before the instrument was 
connected or powered-on, the software will not be able to find the instrument. In this case, close the software 
and make sure the instrument is connected to the PC and is powered on before restarting the software. 

3.2.2 Swapping the Camera 

If two or more cameras are connected to the PC, then the camera may be swapped from within the software.  Exit 
“Live” mode (if appropriate).  Click the “Connect” button for menu item “Connect” under the File menu to launch 
the selection window (see Figure 5).  The first alternate camera available will be highlighted automatically; click 
“OK” to accept the change or “Cancel” to keep the current device. 

 

 

Figure 5 Selecting a Camera (Swapping the Camera) 

3.2.3 Loading a Configuration 

Instrument configurations are stored in JSON files. A default configuration of the last-known settings is always 
loaded upon starting the software. Use the “Load” button or menu item “Load” under the File menu to import a 
specific previously saved configuration. 

3.2.4 Optimizing Filter Intensities 

Under the Setup tab, click the “Live” button to begin real-time image acquisition. The signal intensity on the 
camera must be optimized for each filter in the wheel. The “Home” button moves the filter wheel to Slot 1. The 
filter wheel may be moved to any filter slot by three different methods. 

• Use the pull-down list under Filter Settings. 
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• Use the “Jog CW” (clockwise) or “Jog CCW” (counterclockwise) buttons. 

• Click the desired thumbnail at the bottom of the window. 

 

 

Figure 6 Setup Controls 

Use “Exposure” and “Gain” controls to improve the image intensity. Click the “Histogram” button in the Plot 
Controls Bar to bring up a real-time intensity histogram of the current image (see Section 3.3.2).  

• Type directly into the exposure and gain control boxes. 

• Increment/decrement by the adjacent arrow buttons. 

• Adjust exposure using slider control.  

• Adjust exposure using the “Auto” button. 

• Click the “Reset” button to restore the exposure and gain to the last saved values. 

The gears button will display a summary table of all filter settings and may be used to edit/change any of the 
following (see Figure 7). Note that the filter name may be changed using Options - Filter Wheel (see Section 4.2). 

• Type (Band Pass, Multi-Band, Short Pass, Long Pass, Other) 

• Wavelength 

• FWHM 

• Exposure 

• Gain 

Click “OK” to keep any changes made in the table or “Cancel” to revert to the original values. 

Live On/Off 

Select Filter 

Exposure 

Gain 

View Table 

Reset 

Auto Adjust 

Jog Wheel 
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Figure 7 Filter Settings 

3.2.5 Saving a Configuration 

All configuration changes are immediately written to the default configuration file. Use the “Save” button or menu 
item “Save” under the File menu to store the current configuration file for later use. 

3.2.6 Collecting Data 

The Acquisition tab is shown in Figure 8. Images may be collected as “Single” or “Full Stack” by pressing the 
corresponding button. “Single” collects one image for the current filter wheel position (highlighted thumbnail), 
while a “Full Stack” collects an image for each filter wheel position beginning with slot 1. 

• Storage Settings 

o Storage Path: Click in the text box to manually enter a path or click the ellipsis to browse to a 
folder location. 

o Prefix: Click in the text box to change the prefix. The prefix and system date/time are used to 
generate the image stack name (e.g., “stack_Demo_250505102639.tif” or single image name 
(e.g., “Demo_250505102639.tif”).  

• Acquisition Settings 

o Average Frames: Activate by clicking the checkbox. The number of frames indicated are 
averaged together for each image collected in both “Continuous” and “Total Acquisition” 
modes. 

o Continuous: Images will be collected in order beginning with slot 1 and continuing through 
multiple image stacks until the “Full Stack” button is pressed to stop the acquisition. If the 
“Full Stack” button is pushed during collection of a stack, the user will be prompted to finish 
the current stack or abort image collection. 

o Total Acquisition: A fixed number of image stacks will be collected as indicated in the 
accompanying text box. 
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o Acquisition Delay: The numerical wait time in “Delay Unit” units between image stacks for 
total acquisition mode. 

o Delay Unit: With “Acquisition Delay”, governs the length of time between image stacks. 
Choices are hours, minutes, and seconds. 

• Data Collected: List of image stacks most recently collected.  If the list length exceeds the allotted space, 
a scroll bar/arrows control becomes available. 

• Gallery Setup: Collect new images while cycling through filter slots from 1 – 12, but do not save to disk 
(see Figure 9). 

 

Figure 8 Acquisition Controls 
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Figure 9 Full Image Stack 

3.2.7 Other Features 

Right-click anywhere in the image area to bring up an options menu. 

• Save as: Click to save the current image as a .tif or .jpg file. 

3.3 Plot Bar Controls 

The Plot Bar controls become active as soon as Live mode is activated, or any image has been collected and may 
be used on live or static images. Press the corresponding button on the plot bar to start a plot. 

                                                            

Figure 10 Plot Bar Controls 
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3.3.1 Spectral Intensity Tool 

This feature is active after an image stack has been collected. Click the desired image stack in the “Data Collected” 
list and then press the “Spectral Intensity” button to display the plot. If no region of interest (ROI) has been 
selected, this plot will use the average intensity of each image as the corresponding data points (see Figure 11). 

• Export Data: Save spectrum data to a .csv file. 

 

 

 

Figure 11 Spectral Intensity (Overall Average) 

If one or more regions of interest have been created, then this plot will display the average intensity of the 
highlighted ROI(s) (see Section 3.3.4 and Figure 12).  Additional ROIs may be selected while the Spectrum plot is 
open and will be added to it. 

Data Collected 
Current Image 
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Figure 12 Spectral Intensity (ROI Average) 

3.3.2 Intensity Histogram Tool 

The Histogram is essential for optimizing light intensity for each filter in “Live” mode. Press the “Histogram” button 
to open the plot.  Intensity bins are represented on the X-axis and pixel counts are represented on the Y-axis. 
Hover the cursor over a bar on the plot to display the total for that bin.   

The Histogram may also be used after an image stack has been collected.  While the Histogram is open, click on 
different slot thumbnails to view data for different filters. 

• X-axis Zoom: Slider control to change X-axis view. 

• X-axis Limits: Manually enter minimum and maximum values. 

• Auto Scale X-axis: Automatic adjustment of minimum and maximum values 

• Reset X-axis: Return plot view to original X-axis limits. 

• Export Data: Save histogram data to a .csv file. 

• Y-axis Log Scale: Check to change Y-axis scale for easier viewing of lower-count bins. 
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Figure 13 Histogram Controls 

 

 

Figure 14 Histogram - Log Scale 

3.3.3 Intensity Profile Tool 

The “Profile” button changes the cursor icon in the image area. Press and hold the left mouse button while 
dragging the mouse across the image to draw a straight line. Release the mouse button to end the line. The profile 
plot for the current filter slot will appear. 

Y-axis Log 

Scale 

X-axis 

Zoom 

Export 

Data 
Reset 

X-axis Auto Scale 

X-axis 
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Figure 15 Profile Line 

 

Hovering the mouse over the plotted profile line will display the X and Y coordinates for that point. 

Click in the image area to erase the profile line and draw a new one.  Once a profile line has been drawn, it is 
possible to click from thumbnail to thumbnail to view the same profile line for different filters.   

• Line Width (Pixel): Enter a value in pixels to change the line width of the profile line.  Integer values 1-10 
are accepted.  All pixels captured by this line will be used to compute the profile intensity plot.  

• Export: Save profile data to a .csv file 

 

 

Figure 16 Profile Plot 

 

Close the profile plot to exit the intensity profile tool. 

Export 

Data 
Line Width 
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3.3.4 Draw Rectangle ROI Tool 

Press the “Draw Rectangle ROI” button to activate the tool. Press and hold the left mouse button and draw a 
rectangle on the image to capture the desired region of interest. This process may be repeated to select additional 
regions of interest. To remove a region of interest, click inside the ROI to highlight it and press the delete key. The 
ROI selection tool is used in conjunction with the “Spectral Intensity” button (Section 3.3.1).  There is no limit to 
the number of ROIs that may be defined. 

 

Figure 17 ROI Selection 

3.3.5 Fit Image to Window 

Press the “Fit Image to Window” button to scale the image to fill the image area, while maintaining the aspect 
ratio. 

 

3.4 Status Bar 

3.4.1 Message Area  

Various messages can appear in this area during instrument operation. 

• Ready: Indicates instrument is ready on program start. 

• Frames per Second: Frames per second (FPS) is the imaging rate at which the camera is operating while 
in Live mode. 

• Capturing: Indicates filter wheel motion (e.g., “Jogging to 400-40.”) or current position (e.g., “In slot 400-
40.”). 

3.4.2 Zoom 

Zoom value depends on the application window size, use of the “Fit Image to Window” button, and camera binning 
settings. 
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3.4.3 Cursor Location 

The current cursor position is given in terms of X and Y coordinates (pixels).  

3.4.4 Intensity 

The intensity of the current filter position at the indicated cursor location is given in detector counts. 

3.4.5 Pixel Information 

The current theoretical pixel size is listed. 

3.4.6 Camera Status 

Busy (yellow circle) or idle (green circle) indicates whether the camera is or is not collecting images. 

 

 

 

 

Figure 18 Status Bar (left) 

 

 

 

Figure 19 Status Bar (right) 

 

Chapter 4 Options 

Pressing the “Options” button or the “Settings” menu item in the Options menu will open the Options dialog. Four 
categories are available.  

4.1 General 

• Acquisition File Formats 

o Single Image 

▪ JPEG 

▪ TIFF 

o Full Stack 

▪ OME-TIFF 

▪ TIFF 

• Theoretical Pixel Size 

o Pixel Size: Enter value 

Zoom 

Intensity 

Cursor 

Location 

Message 

Pixel Information Camera Status 
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o Unit: Choose cm, mm, µm, nm 

• Exposure Limit 

o Minimum Exposure Time: Enter value [0 ms lower limit] 

o Maximum Exposure Time: Enter value [10000.0 ms upper limit] 

 

 

 

Figure 20 Layout of the General Options 

 

4.2 Filter Wheel 

The friendly name of each filter slot and associated image color map (default = grayscale) can be edited from this 
window. Press the “OK” button to save any changes. Press the “Reset” button to revert to the default name and 
color setting for each filter. Press the “Cancel” button to leave the settings unchanged. 

 

 

Filter Wheel 

Quick Load Reset to Default 

Load Defaults 

Set Default 
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Figure 21 Layout of the Filter Wheel Options 

 

Click a filter name entry to change the friendly name. The color bar to the right of a filter name shows the color 
scheme on a 0 - 4095 scale to be applied to an image based on the intensity value at each pixel. Click the color bar 
for a filter to select and then click the down arrow to expand the color palette options. Select a new color or 
“Advanced” for customization (see Figure 22).  Use the “Default” button to the right of each filter color bar to 
make that name and color the new defaults for that filter. 

 

Figure 22 Color Options 

The advanced Colormap Editor offers the following means for changing color. Nine colors are used to represent 
an image based on intensity levels (see Figure 23). If accepted, this new color map will appear at the bottom of 
the list as seen in Figure 22. 

• Handle: Click on a handle to select it. Drag it left or right to change the color. 

• Color Bar: Range of colors for this colormap. 

• Color Select: Use the pull-down palette to change the color at the selected handle. 

• Handle Scroll: Move the scroll bar left or right to change the color at the selected handle. 

• Up/Down: Fine adjustments can be made with the up/down arrows or direct entry in the accompanying 
text box. 

• OK: Click to accept colors. 

• Cancel: Do not accept colors. 

 

Advanced 
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Figure 23 Colormap Editor 

Activate “Quick Load” to enable easy replacement of a filter in the filter wheel. Press “OK” to close the Options 
window.  The bottom of the main screen now features the Quick Load “Load” button in the lower left corner (see 
Figure 24). It is visible on the “Setup” tab and is active when “Live” is off. 

 

Figure 24 Quick Load (Load) 

Quick Load Example for Filter 450: 

1. Click thumbnail corresponding to the filter that will be replaced (Figure 24). 

2. Click “Load”.  The filter wheel will rotate 180 degrees to bring the selected filter (450) to the filter access 
port.  The button will change to “Ready” and the filter now in front of the camera will be highlighted (750) 
(Figure 25). 

3. Refer to the Multispectral Imaging System User Guide for instructions on filter replacement. 

4. After the new filter has been loaded into the filter wheel, click the “Ready” button. The filter wheel will 
rotate 180 degrees to bring the selected filter (450) back to the camera.  The button will change back to 
“Load” as seen in Figure 24. 

5. Repeat steps 1-4 to change additional filters. 

6. Edit the filter name, if needed, in the Filter portion of the Options window. 

 

 

Figure 25 Quick Load (Ready) 
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4.3 Camera 

Various camera settings can be adjusted from this window (see Figure 26). Press the “OK” button to save any 
changes. Press the “Default” button to revert to the software’s default settings. Press the “Cancel” button to leave 
the settings unchanged.  If the instrument is in “Live” mode, then camera settings are disabled. 

• General Options 

o Binning: Turn binning on/off [Default=On]. 

o Vertical: Bin pixels on the Y axis with possible values 1-8. Values > 1 will decrease the bottom 
ROI. [Default=1]. 

o Horizontal: Bin pixels on the X axis with possible values 1-8. Values > 1 will decrease the right 
ROI. [Default=1]. 

o Correction: Turn correction on/off [Default=On]. 

o DPC: Defect pixel correction mode [Default]. 

o FPNC: Fixed pattern noise correction mode. 

o ReverseX: Reverses image left to right [Default=Off]. 

o ReverseY: Reverses image top to bottom [Default=Off]. 

• ROI: The camera ROI is the rectangular region on the detector that is used for the images to be collected. 

o Top: Enter value or use arrows to change (minimum = 0). 

o Bottom: Enter value or use arrows to change (maximum = 1216 (HSC23V)). 

o Left: Enter value or use arrows to change (minimum = 0). 

o Right: Enter value or use arrows to change (maximum = 1936 (HSC23V)). 

o Full Frame: Return settings to maximum detector area [Default=maximum area]. 

 

 

Figure 26 Layout of the Camera Options 
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4.4 Miscellaneous 

This window provides access to the theme and language of the software. Click the desired setting to make an 
immediate change. “Theme” is also accessible as a menu option under the Options menu. “Language” is also 
accessible as a menu option under the Options menu. 

 

Figure 27 Layout of Miscellaneous Options 

 

Chapter 5 Help 

5.1 Update 

Press the “Update” button or click the menu item “Update” under the Help menu. 

 

Figure 28 Update 

 

5.2 Support 

Click the menu item “Support” under the Help menu to access the error log and request technical support. 

Miscellaneous 

Theme 

Language 
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Figure 29 Support 

 

5.3 About 

Click the menu item “About” under the Help menu for details regarding instrument components. 

 

 

Figure 30 About 
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Chapter 6 Troubleshooting 

Problem Action 

Software Installation Failed 

Be sure to have administrative rights on your computer 
which enables you to install the software. Ask your system 
administrator to give you such rights or to do the 
installation. 

Software Starts with Inactive Main Screen 

 

Motor power is off, and USB is not connected.  

1. Close software. 

2. Connect USB. 

3. Restore power to motor. 

4. Start software. 

Motor power is on, and USB is not connected.  

1. Close software. 

2. Connect USB. 

3. Start software. 

Software Brings up Error 52 Several Seconds 
into Startup 

 

USB is connected but motor power is off.   

1. Click “Exit” from Alert window.   

2. Restore power to motor.   

3. Start software. 

Or 

1. Restore power to motor. 

2. Click “Continue” from Alert window. 

3. Software will operate normally. 

‘Select a camera to connect’ Appears 
Unexpectedly During Normal Operation 

 

USB cable is loose or has fallen off during operation. 

1. Close software. 

2. Re-attach USB cable. 

3. Start software. 

Jog Error Message 

 

Motor is out of sync with camera. 

1. Acknowledge error. 

2. Close software. 

3. Remove power from motor. 

4. Restore power to motor. 

5. Start software. 
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Problem Action 

Filter Wheel Will Not Change Positions 

This usually occurs when motor power is off. 

1. Close software. 

2. Restore power to motor. 

3. Start software. 

Image is Too Dark 

Remove lens cap. 

Check the scene lighting. 

Increase exposure time or gain if necessary. 

Image is Too Bright or Washed Out 
Check the scene lighting. 

Decrease exposure time or gain if necessary. 

Vignetting observed during image collection.

 

Vignetting can indicate that the filter wheel is not precisely 
centered on the D-hub.  Consult the HSC23V Multispectral 
Imaging System User Guide for instructions on adjusting the 
filter wheel.  If wheel adjustment fails to fix the issue, the 
imaging system may need to have the home position 
reestablished.  Contact techsupport@thorlabs.com for 
assistance. 

If All Else Fails 
Bring up the error log by clicking the “Support” button or 
menu item “Support” under the Help menu. Save it to file 
and attach it to an email to techsupport@thorlabs.com. 

 

 

Chapter 7 Appendix 

JSON configuration file example. Each filter slot (numbered 0-11) has a set of parameters; this example has been 
shortened by omitting filter slots 2-10. 

[ 

  { 

    "SlotName": "FBH400-40", 

    "SlotParameters": { 

      "Color": "Gray", 

      "Type": 0, 

      "Wavelength": 400, 

      "FWHM": 40, 

      "Setting": { 

        "ExposureTime": 24993.131, 

mailto:techsupport@thorlabs.com
mailto:techsupport@thorlabs.com
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        "IsAutoExposure": false, 

        "Gain": 0, 

        "IsAutoGain": false 

      } 

    } 

  }, 

{ 

    "SlotName": "FBH450-40", 

    "SlotParameters": { 

      "Color": "Gray", 

      "Type": 0, 

      "Wavelength": 450, 

      "FWHM": 40, 

      "Setting": { 

        "ExposureTime": 24993.131, 

        "IsAutoExposure": false, 

        "Gain": 0, 

        "IsAutoGain": false 

      } 

    } 

  }, 

… and so on for filter slots 2-10 

  { 

    "SlotName": "FBH950-40", 

    "SlotParameters": { 

      "Color": "Gray", 

      "Type": 0, 

      "Wavelength": 950, 

      "FWHM": 40, 

      "Setting": { 

        "ExposureTime": 24993.131, 

        "IsAutoExposure": false, 

        "Gain": 0, 

        "IsAutoGain": false 
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      } 

    } 

  } 

] 
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Chapter 8 Thorlabs Worldwide Contacts 

For technical support or sales inquiries, please visit us at www.thorlabs.com/contact for our most up-to-date 
contact information.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Corporate Headquarters 
Thorlabs, Inc. 
43 Sparta Ave 
Newton, New Jersey 07860 
United States 
 
sales@thorlabs.com 
techsupport@thorlabs.com 
 

 
Product Manufacturer 
Thorlabs Inc. 
43 Sparta Ave 
Newton, New Jersey 07860 
United States 
 
sales@thorlabs.com 
techsupport@thorlabs.com 
 

EU Importer 
Thorlabs GmbH  
Münchner Weg 1 
D-85232 Bergkirchen 
Germany 
 
sales.de@thorlabs.com 
europe@thorlabs.com  

UK Importer 
Thorlabs Ltd. 
204 Lancaster Way Business Park 
Ely CB6 3NX 
United Kingdom 
 
sales.uk@thorlabs.com  
techsupport.uk@thorlabs.com  

https://www.thorlabs.com/contact
mailto:techsupport@thorlabs.com
mailto:techsupport@thorlabs.com
mailto:europe@thorlabs.com
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